VGS outage - degraded performance with credit card tokenization and processing

Incident Report for Engaging Networks

Resolved

All VGS services are fully recovered and operating normally
Posted Oct 21, 2025 - 12:57 UTC

Update

VGS reports that all the services used by Engaging Networks have recovered. No action is required by Engaging Networks clients to restore credit card processing. We are continuing to monitor and will update this page as needed. Direct VGS status can be found here: https://status.verygoodsecurity.com/
Posted Oct 20, 2025 - 22:02 UTC

Monitoring

The third party application VGS (Very Good Security) used by Engaging Networks to tokenize credit card data is currently experiencing degraded performance (due to an earlier outage with AWS). This could cause credit card donations to fail in Engaging Networks as they cannot be tokenized. Digital wallet, ACH (bank) transactions, and subsequent recurring credit card transactions are not impacted. Direct VGS status can be found here: https://status.verygoodsecurity.com/
Posted Oct 20, 2025 - 16:54 UTC
This incident affected: Payment Gateways.