Problem with credit card number and CVV fields

Incident Report for Engaging Networks

Postmortem

REPORT: Donation Page Credit Card Processing Outage

TIMELINE AND IMPACT

Date: July 6th, 2026

Timing: 3:07 PM - 5:30 PM ET (approx. 2.5 hrs)

Impact: US, US2 and CA datacenters. Credit Card donations on most Page Builder donation pages, including pages submitted via the REST API. No other page types or services were impacted. 

SUMMARY

During a scheduled hotfix deployment at 3:07 PM Eastern, an unreleased future configuration intended for a payment gateway was inadvertently included in the production environment. While this configuration change was expected to remain dormant until the official gateway release, a code path within the live donation application unexpectedly read the new configuration data.

Because the code was not equipped to process this premature data, it triggered a silent error that disabled credit card processing across most client-facing donation pages. Engaging Networks began to receive internal alerts and client reports that credit card fields were not functional and immediately began to investigate. Shortly after the issue was discovered, a fix was deployed, reverting the configuration change at approximately 5 PM ET and began to propagate across client pages. The issue was fully resolved and services were entirely restored by 5:30 PM Eastern.

Not impacted:

  • Smart Pages
  • Digital wallets (Stripe GooglePay and ApplePay, Vantiv Worldpay ApplePay, and PayPal One Touch and express check out)
  • Pages using the BBIP payment gateway

NEXT STEPS

We are establishing a stricter policy that no production configuration changes for new features or gateways will be deployed ahead of time. Going forward, configurations will only be pushed to the production environment on the exact day of the official feature release. This completely eliminates the risk of unreleased or "dormant" configurations creeping into production prematurely.

Posted Jul 10, 2026 - 13:26 UTC

Resolved

This issue has been resolved and the credit card fields are working as expected now. Engaging Networks is continuing to monitor and will provide a technical assessment with further details.
Posted Jul 06, 2026 - 21:35 UTC

Monitoring

A fix has been implemented in all data centers and is propagating to all client pages. Engaging Networks is continuing to monitor.
Posted Jul 06, 2026 - 21:16 UTC

Identified

The problem has been identified and a fix is being deployed in all data centers.
Posted Jul 06, 2026 - 20:55 UTC

Investigating

Engaging Networks is investigating an issue preventing data from being input in the credit card number and CVV fields on client pages in the US, US2 and CA data centers. We will update this page when more information is available.
Posted Jul 06, 2026 - 20:17 UTC
This incident affected: Payment Gateways.