Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 27, 2026 - 03:00 UTC
Scheduled
Engaging Networks will be unavailable for a period of no more than 90 minutes for a scheduled maintenance event.
During this time, the system is intentionally taken offline and users temporarily lose access to the platform. This is to ensure that updates can be applied safely, resulting in better performance, reliability, and security once services resume.
For the duration of the maintenance period: - Email jobs and scheduled profile runs are paused. They will restart once the maintenance is completed. - The platform will experience intermittent availability.
Posted Jun 26, 2026 - 20:17 UTC
This scheduled maintenance affected: Application, Data & Reporting, and Messaging.